Announcement

Collapse
No announcement yet.

Betfair - New version 1.4z released

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The other Geek
    replied
    http://www.geekstoy.com/forum/showth...-1-5a-released

    Leave a comment:


  • dovj
    replied
    Originally posted by valve View Post
    After 2 trading days 2 freezes. No idea how this can affect freezing but I just set STREAM PRICES ON, seems more stable now. Freezes I got were after many hedge bets placed by tick offset. As you can see there is 1 bet completely off the odds (again 2 E stake that was the problem in previous version now placed at 1.04).

    [ATTACH=CONFIG]2526[/ATTACH]

    Dovj, what are your API settings (numbers in API manager) please? What price display do you use (standard, hybrid, or complete)?
    Hi,
    In my image attached I have the same 1.16 bet off with 0.06eur, but it can be just hedge playing out... maybe this is the issue? Geek? What your wonderful brain says?

    I have used the same api settings for some years, no problems, but with this version I already changed something, what was recommended in other post about current bf lags (about 30sec before the off markets freezes for few secs, and another consistent lag of market depth for 1-2 secs, you can see it by placing bets and canceling them, market depth really delays my bets for 1-2 secs, which was never a case before) ....

    Really betfair making things very hard, if trading against all HFT bots is not still not enough. Well after geekstoy freeze and restart these my new API settings was reset so posting my old settings, which worked fine for some years... http://prntscr.com/tdilw9 . With new settings I got freeze so probably no connection with that. Good luck, will trade only Friday and Saturday Hope no freezes until then

    Leave a comment:


  • valve
    replied
    After 2 trading days 2 freezes. No idea how this can affect freezing but I just set STREAM PRICES ON, seems more stable now. Freezes I got were after many hedge bets placed by tick offset. As you can see there is 1 bet completely off the odds (again 2 E stake that was the problem in previous version now placed at 1.04).

    Click image for larger version

Name:	Untitled.jpg
Views:	1
Size:	15.1 KB
ID:	206676

    Dovj, what are your API settings (numbers in API manager) please? What price display do you use (standard, hybrid, or complete)?

    Leave a comment:


  • valve
    replied
    2 freezes for yesterday, 1st time after tick offset hedged bets but these bets were well over 2 E, 2nd time after I moved couple of bets on ladder to lower odds. I am trying something else, if it works I ll let you know.

    Leave a comment:


  • dovj
    replied
    Got first freeze today, I took screenshot to share. Please see matched and unmatched stakes if any help of it. Click image for larger version

Name:	freez.jpg
Views:	1
Size:	20.4 KB
ID:	206675
    https://prnt.sc/tbt2d0
    For some reason my image is very small so added link to other service.

    Leave a comment:


  • valve
    replied
    I think I know whats the cause of this freezing. As I have API status shown I can see new error message bet too small. This message is shown when I hedge with small bets manually (tick offset off). However, I dont see this message when tick offset is on. I am not a programmer, but could these 2 things (error message together with tick offset trying to place small bet) cause any kind of collision?

    Leave a comment:


  • valve
    replied
    Seems to me it happen at random time. I have like 2 freezes for trading day. Once it happened just in 1st minute I opened ladder, next time just at the end of the day, and I think every time I had some unmatched bets placed. Maybe some small hedge bets are causing this as I use tick offset. So really strange and dangerous. I have to investigate further.

    As you mentioned it freezes close to start of the race when you hedge, so this could really mean something with placing small bets.
    Last edited by valve; 4 July 2020, 01:13 PM. Reason: additional info

    Leave a comment:


  • dovj
    replied
    Originally posted by valve View Post
    Hi dovj, I dont use any video but it freezes when I have open ladder. Maybe this correction for minimum bets affects it somehow.
    Hi, yes, you are right, got another freeze without clicking video button, probably was a coincidence last time. You get freeze only when doing betting? Or its just enough to have opened ladder? I am always doing scalping with tick offset near the start (tick offset with low stakes and Hedge checked), it might be something with minimum bets as you say. Freeze count : 3 . All of them happened around 00:00 time , near the off But still lucky not to loose these bets when markets gets in-play.

    Leave a comment:


  • valve
    replied
    Hi dovj, I dont use any video but it freezes when I have open ladder. Maybe this correction for minimum bets affects it somehow.

    Leave a comment:


  • dovj
    replied
    2nd freeze I got was after pressing to watch market video button. Can be that new horse racing video format is causing problem.

    Leave a comment:


  • valve
    replied
    This version is freezing for me as well.

    Leave a comment:


  • InvisibleLayer
    replied
    Originally posted by InvisibleLayer View Post
    Rolled back the windows 2004 update back to 1909. Resinstalled this Z version and its fine again.
    Worked out it was due to changing the prices to 1000ms yesterday, works fine when set to a quicker refresh. Started up again when set to a 1 second refresh.

    Leave a comment:


  • dovj
    replied
    Hi,
    Today new version crashed (froze) on me before just race started on short race with all balance bet ... due fast traders reaction I was able to start program again and exit position in-play. Just reporting something to look into. If it will happen again probably I will have to revert back to older version (very very annoyed by hedging but still better than losing all in). Have a nice day

    Leave a comment:


  • InvisibleLayer
    replied
    Rolled back the windows 2004 update back to 1909. Resinstalled this Z version and its fine again.

    Leave a comment:


  • InvisibleLayer
    replied
    Noticed on the market overview lines once they get to the end on the left they jump back in to this point as in the screenshot and then it keeps repeating, not noticed this until today. I cleared all files and installed again, its either the new beta or windows update 2004 build I did today. Can anyone check to see if the same issue? was set at 300 seconds and fine, streaming chart history is set right. Tried the chart range at 10 seconds it hits the end and then blank, so worse.

    Click image for larger version

Name:	Annotation 2020-07-02 195813.jpg
Views:	1
Size:	12.7 KB
ID:	206674

    Leave a comment:

Working...
X