Page 3 of 3 FirstFirst 1 2 3
Results 41 to 47 of 47

Thread: Geeks Toy now runs on Linux

  1. #41
    Virgin
    Join Date
    Nov 2009
    Posts
    3
    Thanks: 0
    Thanked 0 Times in 0 Posts

    Default

    Hello geeks

    I installed with my Toy using ubuntu but I got error Crash Bug ATG (find attached) when I log in and after I installed the components:


    Ubuntu 10.04.4 LTS

    Linux ubuntu 2.6.31-22-generic #73-Ubuntu SMP Fri Feb 11 17:36:01 UTC
    2011 i686 GNU/Linux

    Wine –version: wine-1.4

    Components DLL:
    1) allfonts
    2) dotnet20 and dotnet20sp2
    3) msscript
    4) msxml4 and msxml6
    5) vb6run
    6) vcrun2008

    Can someone help?

    Thank you very much!
    Attached Files Attached Files

  2. #42
    Virgin
    Join Date
    Nov 2009
    Posts
    3
    Thanks: 0
    Thanked 0 Times in 0 Posts

    Default

    Hello Jessica 21

    I'm sorry I did not understand, you mean that installing on Centos Toy does it work?

  3. #43
    Novice
    Join Date
    Oct 2011
    Location
    Poland
    Posts
    12
    Thanks: 4
    Thanked 6 Times in 5 Posts

    Default

    Hi enzotto,
    it doesn't matter which linux distribution you use, there is no real difference between them. Ubuntu is the one most popular, you would easily find help for any problem.
    In one of my previous posts I wrote a detailed instruction how to setup Toy using Playonlinux. You will not run Toy on wine v. 1.4, it just doesn't work with it. You have to choose such old as 1.3.28 or the newest one 1.5.13. I tried it today, on 1.5.13 AGT works with just dotnet20 and allfonts. I don't know if the rest components is required, as I didn't notice any difference after installing them also.
    The trouble is you need new version of winetricks, I have 20120912. In new versions of wine there is mono built in and only the newest winetricks is able to remove mono and install dotnet20 correctly. I'm not sure which one is provided by Ubuntu 10.04, as I use 12.04 and I'm afraid it could be an old one.
    So, my advice is don't look for other linux distributions for example CentOs, as you would do everything the same with Ubuntu, even faster. But maybe you would need to upgrade it to new version.
    The thing is I don't know if it's worth your efforts. In my case I'm able to install The Toy and run it on my machine, but it is so painfully slow, that it's unusable anyway. I have rather old computer, maybe that's the problem, but with Windows The Toy is lightning fast, so in my opinion it's the wine that is not ready yet.
    I hope it's understandable enough

  4. #44
    Novice
    Join Date
    Apr 2012
    Posts
    10
    Thanks: 8
    Thanked 7 Times in 2 Posts

    Smile Toy on Linux

    Hello everyone.

    I've been reading this thread with interest as I've been looking at running the Toy on some small portable hardware (Netbook/Tablet etc. so I can work on the road) and had come to the conclusion via another thread on here that the only way to do that was on a device that runs Windows natively (there is a solution for 'phones running Android which I'm using but that's not relevant here). As most of the Netbooks/Tablets run other OS's besides Windows I thought that left me with a slightly limited choice of hardware so was still looking for a solution.

    After reading through the posts I see you are attempting to run the Toy in some sort of Windows emulation mode on Linux (correct me if I'm wrong).

    From my experience (over 20 years in IT) running emulation on any device will never match the performance natively as I'm sure we all know, unless you throw some serious hardware at the problem, even then you have to question why you're doing it if it can be run on a Windows box that doesn't have to be particularly powerful?

    I have Windows XP and Windows 7 virtual machines running (alternately) in the freeware VMware ESXi 3.5 server on a HP quad-core Xeon box with 8GB RAM (£200 Ebuyer) + whilst it runs everything fine even my 6 year-old Intel Centrino-equipped 2GB RAM laptop (I'm saying it's not very powerful) is faster by comparison running the Toy because it's not having to go through any emulation/conversion routines. Also another forum member says he runs it fine on a Netbook under Windows 7 with an Atom processor + 1GB RAM just as quickly as his i5 processor-equipped laptop.

    That suggests then that any emulation will be somewhat slow/problematic unless you have some very powerful hadrware to run it on, and the issue then becomes the cost to performance ratio of trying to do this.

    I'm not saying you shouldn't persevere, just that you should be aware of the inherent limitations of this method until a more efficient version of WINE etc. comes out or the Toy is ported.

    I will continue to investigate this as I'm still not sure what hardware I'm going to get to be able to work outside besides my 'phone, so if I come across a solution or anything useful/relevant I will post it here.

    Finally could someone please clarify which versions of Linux/emulation has been used? I'll then try another version or two in a VMWare guest and report back.

    Thanks.

    P.S. I worked mainly with Windows over the years so Linux is still something of a mystery to me so forgive any newb assumptions I may have made above.

  5. #45
    Novice
    Join Date
    Oct 2011
    Location
    Poland
    Posts
    12
    Thanks: 4
    Thanked 6 Times in 5 Posts

    Default

    Hi lucky,

    WINE stands for "Wine Is Not an Emulator". That's a quote from its site: "WINE is a compatibility layer capable of running Windows applications on several POSIX-compliant operating systems, such as Linux, Mac OSX, & BSD. Instead of simulating internal Windows logic like a virtual machine or emulator, Wine translates Windows API calls into POSIX calls on-the-fly, eliminating the performance and memory penalties of other methods and allowing you to cleanly integrate Windows applications into your desktop."

    And "Some people argue that since Wine introduces an extra layer above the system a Windows application will run slowly. While technically true, Wine is no different from any other software library in this regard; even newer versions of Windows must load extra resources to support older applications.
    Importantly, the combination of Wine and Unix can sometimes be faster than Windows itself. This is especially true when the system has good drivers and the application isn't exposing any Performance Related Bugs." OpenGL applications often work faster in Linux under Wine than natively in Windows.

    The problem with AGT is that it is written in .NET, which is closed and unsupported on other systems than Windows. By some sometimes dirty and not officially supported tricks (Winetricks) it's possible to install some versions of .NET (dotnet20, dotnet30 and so on) in Wine but it's not compatible hence those performance drops and bugs in AGT under Linux+Wine. If AGT was build with Java for example, which is platform independent there wouldn't be any problems with running under Linux or MacOs or Android (which is some sort of linux too). It could even work faster than in Windows.

    The Toy is the only reason why i still need a Windows partition, everything else I do with Linux. I use Ubuntu 12.04 and the newest WINE 1.5.13, but as I said before AGT runs too slow to be usable. I have also tried to emulate Windows with VirtualBox for some time but Toy was significantly slower too. There is no better solution to run AGT elsewhere than on native Windows system. It's possible to run it in some virtual machine, but it will always be slower in this case.

  6. The Following 2 Users Say Thank You to elmiguello For This Useful Post:
    Malamadre (4th December 2012), XenoMorph (15th October 2012)
  7. #46
    Novice
    Join Date
    Feb 2012
    Location
    LV
    Posts
    5
    Thanks: 1
    Thanked 8 Times in 2 Posts

    Default

    Hi!
    Finally I manage to run geek toy on my linux box!

    1. Largest issue was, that I'm using 64bit distribution, and dotNet2 works properly only in 32bit machines! So if You are using 64bit distribution firstly check if You have all 32bit lib dependencys! For wine I have installed (you can google for names, because those names are from linux arch comunity repositories):
    - lib32-openal (already installed)
    - lib32-libxml2 (already installed)
    - lib32-mpg123 (already installed)
    - lib32-giflib (already installed)
    - lib32-libpng (already installed)
    - lib32-gnutls (already installed)
    and
    - lib32nss-mdns (I could run geek toy without it, but there was network problem, so none 32bit network related application wont work without it)

    here are additional info (but there I dont see info about nss-mdns):
    http://wiki.winehq.org/WineOn64bit

    next I'll post bash commands to set up geek toy in linux enviroment:
    # set up 32bit wine arhitecture
    export WINEARCH=win32

    # set new wine geek toy prefix
    export WINEPREFIX=/home/$USER/.GeekToy

    # remove mono (open source dot net implementation)
    # for now it not so stable to run geek toy so remove it
    # also possible that it isnt installed, so if there are error, just ignore it
    wine uninstaller --remove '{E45D8920-A758-4088-B6C6-31DBB276992E}'

    # install dotNot throught winetricks (geek toy are based on dotnet so its)
    winetricks dotnet20

    # and by now geek toy runs for me, there was some font problem and layout problem, but I could trade with geek toy

    # next steps are to remove some visual glitches
    # install fonts,
    winetricks allfonts
    # for me its end with error, but thats ok, because it installs all fonts nescesary

    # fix for geek toy layout, border fix
    winetricks gdiplus
    # just follow winetricks instrucion, it will open folder where You need to put file which You need manualy download
    # after that reexecute command: "winetricks gdiplus"

    # and at last You can install geek toy on this prefix
    msiexec /i "PATH_TO_GEEK_TOY_INSTALL_FILE"


    # everything now is done, I hope that wine creates schortcut for You, but if in case if You need open geek toy from terminal do following steps
    export WINEARCH=win32
    export WINEPREFIX=/home/$USER/.GeekToy
    env WINEPREFIX=/home/$USER/.GeekToy WINEDEBUG=-all wine "C:\Program Files\The Geek\AGT Pro - Betfair\AGT Pro.exe"
    # I run geek toy with wine param: WINEDEBUG=-all, it suppress any wine log
    I have following issues:
    1. Geek toy icon wont show in fast app switching popup box (alt+tab)
    2. Windows moving its little strange (but it seems problem with my windows manager: xfce4)
    as a workaround I can use: disabling following option in winecfg: "Allow the window manager to control the windows". (I dont know if there is such option in older releses), but after disabling it, I have problem, that geek toy appears in all my viewports.
    3. Some time geek toy hangs after I log in (then I just kill app and reopen).
    4. Don't install crypt32 and secur32 (in my case they broke down geek toy)

    I hope that this information helps!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot - 11252012 - 10:51:32 PM.jpg 
Views:	519 
Size:	21.2 KB 
ID:	1233  

  8. The Following 4 Users Say Thank You to Rublis For This Useful Post:
    elmiguello (28th November 2012), Malamadre (4th December 2012), snale153 (19th January 2013), XenoMorph (14th June 2013)
  9. #47
    Virgin
    Join Date
    Jan 2012
    Posts
    2
    Thanks: 0
    Thanked 1 Time in 1 Post

    Default How to youtube video (portuguese)


  10. The Following User Says Thank You to nuno_eczty For This Useful Post:
    Rublis (23rd August 2014)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Talented Mavericks Limited
26 Buttercup Close
Corby
Northants
England
NN18 8LB

UK Company # 04872848
UK VAT # 887366268

Facebook TwitterYouTube



Betfair    Betdaq    VISA  Mastercard  American Express  Dinners Club  Discover  PayPal  Skrill