Results 1 to 13 of 13

Thread: Problem installing Geek Toy on new Pc with windows 10

  1. #1
    Member
    Join Date
    Jul 2010
    Posts
    42
    Thanks: 35
    Thanked 21 Times in 11 Posts

    Default Problem installing Geek Toy on new Pc with windows 10

    Yesterday just got a new PC with windows 10 installed. This evening I have downloaded Geeks Toy. Now when I click to start the install process of Geek Toy software get message "This setup requires the .Net framework version 2.0. Please install etc.". The install software is asking me whether I want to install version 2 framework Yes or No. Some help would be appreciated. Googled .Net and this is 2009 software. I clicked No do not install but this means I cannot install Geek Toy.

  2. #2
    Support Team The other Geek's Avatar
    Join Date
    Nov 2011
    Posts
    631
    Thanks: 10
    Thanked 263 Times in 153 Posts

    Default

    It's .Net 3.5 you are after, if you want to run the Toy.

  3. #3
    Member
    Join Date
    Jul 2010
    Posts
    42
    Thanks: 35
    Thanked 21 Times in 11 Posts

    Default

    I googled .Net 3.5, this was released in 2007, also looks really complicated, something for experts. Does Geeks toy install on a brand new computer with windows 10 or do I need to download extra Microsoft software as windows 10 incomplete and needs extra software before Toy will run ?
    I am reluctant to download complicated additions to the operating system software on a brand new PC.
    I will have another look at download page. Are there some install notes saying what to do.
    Geeks toy ran on my XP and Vista systems fine as long as I kept them up to date with patches. But this is brand new PC and not want to start adding software I do not understand to the operating system.

  4. #4
    Support Team The Geek's Avatar
    Join Date
    Aug 2009
    Posts
    7,439
    Thanks: 322
    Thanked 7,693 Times in 2,126 Posts

  5. #5
    Member
    Join Date
    Jul 2010
    Posts
    42
    Thanks: 35
    Thanked 21 Times in 11 Posts

    Default

    Thanks for the link
    I have started reading thru it.

    Microsoft .NET Framework 3.5 Service Pack 1
    Date Published: 11/18/2008
    System Requirements :-
    Supported Operating Systems
    Windows Server 2003, Windows Server 2008, Windows Vista, Windows XP

    Re system requirements - the Microsoft info says for operating systems up to windows Vista
    Does not mention windows 7,8 or 10
    This looks like old software from 2008
    Is it really needed on new PC with windows 10 ?
    Do not want to mess up brand new computer downloading something I not understand.

  6. #6
    Support Team The Geek's Avatar
    Join Date
    Aug 2009
    Posts
    7,439
    Thanks: 322
    Thanked 7,693 Times in 2,126 Posts

    Default

    Yes it is needed.

  7. #7
    Member
    Join Date
    Jul 2010
    Posts
    42
    Thanks: 35
    Thanked 21 Times in 11 Posts

    Default

    I have been searching forums for help.
    Concluded so far that :-
    * Windows 10 comes with .Net 4.5 framework installed
    * Geeks toy needs .Net 3.5 Framework for it to be installed and run
    * so I need to install .Net 3.5 Framework onto a brand new PC with Windows 10 operating system installed that already has .Net 4.5 framework installed
    * these 2 frameworks can both be installed and run together without problems
    Have I understood things correctly.
    I do not want to mess up my new PC by downloading some old software from Nov 2007.
    If this patch/utility needed and safe to use why do Microsoft not include it in Windows as standard.

  8. #8
    Support Team The Geek's Avatar
    Join Date
    Aug 2009
    Posts
    7,439
    Thanks: 322
    Thanked 7,693 Times in 2,126 Posts

    Default

    Yes you have, and that last question is best directed to Microsoft.

  9. #9
    Member
    Join Date
    Jul 2010
    Posts
    42
    Thanks: 35
    Thanked 21 Times in 11 Posts

    Default

    OK Thanks, will direct to Microsoft, have you got Bill Gates email address by any chance.

  10. #10
    Member
    Join Date
    Jul 2010
    Posts
    42
    Thanks: 35
    Thanked 21 Times in 11 Posts

    Default

    Got the .Net installed and Geek toy then installed smoothly and now working well.

  11. The Following User Says Thank You to peter44 For This Useful Post:
    kawasaki (8th February 2016)
  12. #11
    Member
    Join Date
    Mar 2011
    Posts
    38
    Thanks: 0
    Thanked 0 Times in 0 Posts

    Default

    i just installed windows 10 but geeks running very slow not smooth at all , do i need to unable net 4.6 so that net 3.5 that is enabled works better ? ive tryed it and seems be going better think ?

  13. #12
    Blasphemer Firkinelle's Avatar
    Join Date
    Oct 2009
    Posts
    3,556
    Thanks: 629
    Thanked 3,732 Times in 1,482 Posts

    Default

    Look at posts 7 & 8 - you need Net 3.5 for the Toy
    When I die and they lay me to rest,
    I'm gonna get pissed with Georgie Best

  14. #13
    Member
    Join Date
    Mar 2011
    Posts
    38
    Thanks: 0
    Thanked 0 Times in 0 Posts

    Default

    changed compatibility to run on windows 8 seems be working ok now , net 3.5 already comes installed on windows 10 so was already enabled

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Talented Mavericks Limited
26 Buttercup Close
Corby
Northants
England
NN18 8LB

UK Company # 04872848
UK VAT # 887366268

Facebook TwitterYouTube



Betfair    Betdaq    VISA  Mastercard  American Express  Dinners Club  Discover  PayPal  Skrill